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Chapter 1

 

Introduction

 

Overview

 

Premise Research Software, a software package provided by West, gives you the ability to access and 
search material stored on compact discs and other magnetic media. Premise was designed for use with 
West CD-ROM Libraries but can also be used to search other media.

The purpose of the 

 

Premise Technical Reference Manual

 

 is to explain how to:

 

■

 

configure Premise on a local area network 

 

■

 

copy West CD-ROM Libraries to your hard drive

 

■

 

install and remove books from the Library

 

■

 

set up preferences

 

■

 

select a printer

 

■

 

set up Client Validation

 

■

 

troubleshoot Premise 

This manual does not explain how to perform research in West CD-ROM Libraries using Premise. 
Refer to the 

 

Using Premise 

 

manual that is included with your Premise software package for specific 
research instructions.

For help with installing Premise, see 

 

Installing Premise 4.2.0 on a Network

 

 and 

 

Installing Premise 
4.2.0 for a Single User 

 

installation instructions included with the Premise 4.2.0 software package. The 
installation instructions are also available on the Premise 4.2.0 CD-ROM.



 

Equipment Requirements

2 Premise Technical Reference Manual

 

Equipment Requirements 

 

*Due to performance inconsistencies, use of a Premise Network in a peer-to-peer environment is not supported 
by West. Also, West does not support the use of Premise CD-ROM data with Novell’s CDROM.NLM and 
CDROM.NSS file systems.

†If you are running Windows NT 4.0, Service Pack 6 is required. To download Service Pack 6, go to the Microsoft 
Windows NT Service Packs page at hhhhttttttttpppp::::////////ssssuuuuppppppppoooorrrrtttt....mmmmiiiiccccrrrroooossssoooofffftttt....ccccoooommmm////SSSSuuuuppppppppoooorrrrtttt////NNNNTTTTSSSSeeeerrrrvvvveeeerrrr////CCCCoooonnnntttteeeennnntttt////SSSSeeeerrrrvvvviiiicccceeeePPPPaaaacccckkkkssss////
DDDDeeeeffffaaaauuuulllltttt....aaaasssspppp

 

. Then click SSSSeeeerrrrvvvviiiicccceeee    PPPPaaaacccckkkk    6666

 

 under Windows NT version 4.0. Read the 

 

i

 

nstructions before you download 
the file.

 

Equipment Premise 4.2.0

 

*

 

Premise Network

 

Operating 
system

Windows 98, Windows 
Me, Windows NT 4.0 
SP6†, Windows 2000, or 
Windows XP

Windows 98, Windows 
Me, Windows NT 4.0 
SP6†, Windows 2000, or 
Windows XP

Monitor VGA or higher 
resolution monitor 
(Super VGA 
recommended)

VGA or higher 
resolution monitor 
(Super VGA 
recommended)

Processor 486DX 66 or higher 
processor (Pentium 
required for
Windows Me,
Windows NT, 
Windows 2000, and 
Windows XP)

486DX 66 or higher 
processor (Pentium 
required for
Windows Me, 
Windows NT,
Windows 2000, and 
Windows XP)

Modem or 
server

9600 bps or faster 
modem (14400 bps 
recommended) or local 
area network (LAN) 
communications server 
(TCP/IP, Eicon)

9600 bps or faster 
modem (14400 bps 
recommended) or local 
area network (LAN) 
communications server 
(TCP/IP, Eicon)

Memory 24MB (16MB minimum) 
if running Windows 98 

32MB (28MB minimum) 
if running Windows NT 
or Windows Me

128MB if running 
Windows 2000 or 
Windows XP

24MB (16MB minimum) 
if running Windows 98 

32MB if running 
Windows NT or 
Windows Me

128MB if running 
Windows 2000 or 
Windows XP

Hard disk 
space

30MB 60MB
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Local Area Networks (LANs)

 

Premise has been tested in specific configurations with many network setups. If your network operating system or
CD-ROM server package is not included in this chapter, it is not necessarily incompatible. For the most recent 
compatibility information, please call West Customer Technical Support at 1-800-888-9907.

 

Customer Support

 

Westlaw Technical and Search Assistance (available 24 hours a day)

 

If you have general or technical questions about Westlaw, call West Customer Technical Support at 

 

1-800-888-9907 or send an e-mail message to 

 

west.support@thomson.com

 

.

If you have search questions about Westlaw, call the West Reference Attorneys at 

 

1-800-888-9907 or send an e-mail message to 

 

west.referenceattorneys@thomson.com

 

.

Technical and search assistance is also available online at 

 

www.westlaw.com/customersupport

 

.

Law students with general, technical, or search questions about Westlaw can call 

 

1-800-850-WEST (1-800-850-9378) or send an e-mail message to 

 

west.student@thomson.com

 

.

 

Accessibility Support

 

For information on West’s accessibility policy, go to 

 

west.thomson.com/accessibility

 

 

or send an e-mail message to 

 

west.accessibility@thomson.com

 

.

 

Billing and Account Assistance

 

For billing and account assistance, call 1-800-328-4880. 

Billing and account assistance is also available online at 

 

west.thomson.com/customerservice

 

.

 

Westlaw Training

 

For information about Web-based training, telephone training, or in-person training, visit 

 

west.thomson.com/training

 

.
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Chapter 2

 

Configuring Premise
on a Local Area Network

 

Overview

 

This chapter shows you how to

 

■

 

configure Premise on a network

 

■

 

set up Premise for multiple users on a network

 

■

 

control which settings users can change

 

■

 

run a silent installation

For instructions on installing Premise on a network, see the 

 

Installing Premise 4.2.0 on a Network

 

 
installation instructions included with the Premise 4.2.0 software package.

 

LAN Configuration

 

Premise can be used in many different configurations on a local area network (LAN). There are five 
distinct components of a LAN setup for Premise: 

 

■

 

the file server

 

■

 

the CD-ROM server

 

■

 

CDVOLUME.INI file

 

■

 

the Premise application location

 

■

 

modem communication server (optional)

These components can all be set up on one computer or they can be spread out over many computers. 
It is also possible to have each component set up on a different computer.

 

File Server

 

The file server is a single computer on the LAN where the license control files and the administrative 
programs for Premise are loaded. License control files allow you to access the discs in your West
CD-ROM Libraries according to the number of licenses you have purchased.
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CD-ROM Server

 

The CD-ROM server is the computer to which the CD-ROM drives are attached. You can have one or multiple
CD-ROM servers. The CD-ROM server does not have to be the same computer as the file server, but it can be.

Multiple individual CD-ROM drives or towers are recommended for multiple-disc libraries. CD-ROM changers and 
jukeboxes often restrict the number of users able to access information at one time and delay users’ ability to search 
discs.

Premise can search local and server CD-ROM drives from the same computer.

 

CDVOLUME.INI File

 

The CDVOLUME.INI file contains information about how Premise locates the data on the discs. The system 
CDVOLUME.INI file is located in the library directory. A second CDVOLUME.INI file can be located in the user’s 
working directory, e.g., \WESTWIN\Premise. The CDVOLUME.INI file can contain any changes required for a 
specific user.

You can set tree structure, jukebox, local, unavailable and network settings in the [DRIVE] section of the 
CDVOLUME.INI file.

The following table explains each of the CDVOLUME.INI file [DRIVE] settings.

 

Tree Structure

 

Unlike dynamic mapping, the Premise Tree Structure allows Premise to access groups of CD-ROM discs located in 
subdirectories on a CD-ROM server. These groups of CD-ROM discs, often called CD-ROM Volume Groups, are 
created with utilities provided by the CD-ROM server software.

To access a CD-ROM Volume Group through the CD-ROM server software, map a drive letter to the CD-ROM 
Volume Group.

j = tree Use this to specify the drive letter of your
CD-ROM server if the server supports mounting 
all drives as a subdirectory off the root directory.

j = jukebox Use this to specify the drive letters of a local 
jukebox or changer. Use jukebox to disable 
Premise from trying to mount all the drives to get 
volume information, which can be very slow. 
The installation dialog box will not display 
volume information.

j = local Use this to specify that your drive is local.

j = unavailable Use this to prevent your local drive from 
showing as a valid drive.

j = network Use this to specify a networked CD-ROM drive. 
Premise will not detect non-MSCDEX drives 
(e.g., SCSI Express).
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In the following example, the CD-ROM Volume Group has been mapped to drive K.

Edit the CDVOLUME.INI file, which is located in the library directory, (\Premise\LIBRARY), as in the following 
example:

[DRIVE]

k = tree

The subdirectories must be titled with the WPC number that appears on the front of each West CD-ROM disc. The 
following diagram shows an example of the structure of a volume group.

Volume Group

WPC00061

WPC00062

WPC00063

 

If the CD-ROM Volume Group is created as a Novell NetWare volume or a Microsoft Shared Resource, you can access 
the Volume Group directly (without mapping a drive letter) by using the Universal Naming Convention (UNC).

[DRIVE]

\\server\volume = tree (Novell NetWare)

\\server\sharename = tree (Windows NT)

 

Accessing Network CD-ROM Drives

 

You can access the network CD-ROM drives by editing the CDVOLUME.INI file, which is located in the Library 
directory (\Premise\LIBRARY).

The following example shows how to add each network CD-ROM drive letter to the drive section of the 
CDVOLUME.INI file:

[DRIVE]

j=network

k=network

l=network

 

Accessing CD-ROM Changers and Jukeboxes

 

If you are using a locally attached CD-ROM changer or jukebox, edit the CDVOLUME.INI file and set the CD-ROM 
drive letters equal to jukebox, as in the following example:

[DRIVE]

j=jukebox

k=jukebox

l=jukebox
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The WINPR30.INI File

 

The WINPR30.INI file contains information about your Premise setup, including workstation preferences, menu 
options, Westlaw settings and library settings. The WINPR30.INI file is located in the Premise system directory, e.g., 
X:\APPS\Premise\WINPRS.

If you configure the files in the system directory as read-only, users can create a new WINPR30U.INI file in their 
individual directories by changing their preferences. However, the WINPR30.INI file located in the system directory 
can overrule any personal WINPR30U.INI settings. This enables the system administrator to specify which options the 
user can and cannot modify. This is done by editing the WINPR30.INI file located in the system directory and typing 

 

locked= 

 

below the heading of each section for which you want to restrict access. You can edit this file using any text 
editor. 

Type 

 

locked= 

 

below each section to which you would like to restrict access, including the following:

Workstation Preferences
To prevent users from modifying their workstation preferences, type 

 

locked=

 

 below the [PREFERENCES] line in the 
WINPR30.INI file, as shown below:

[PREFERENCES]

locked=

 

Menu Options

 

To prevent users from modifying their Westlaw sign-on options, type locked= below the [MENUOPTIONS] line in 
the WINPR30.INI file, as shown below:

[MENUOPTIONS]

locked=

Westlaw
To restrict users from making changes to their Westlaw terminal identifier and automatic password settings, type 
locked= below the [Westlaw] line in the WINPR30.INI file, as shown below:

[Westlaw]

locked=

Library
To restrict users from installing or removing books from their library list, type locked= below the [LIBRARY] line in 
the WINPR30.INI file, as shown below:

[LIBRARY]

locked=



File Locations

Premise Technical Reference Manual 9

File Locations
The File Locations dialog box, as shown below, is designed to make it easier to edit scripts and initialization files and 
to set and verify the locations of Premise directories. 

You can access the File Locations dialog box by choosing File Locations from the Help menu in Premise.

The application and user/working directories are displayed in the File Locations dialog box. You can also edit the 
library, common and public directories in this dialog box.

Application Directory
The application directory, e.g., \Premise\WINPRS, contains the Premise executable file and all files needed to run the 
executable file (e.g., DLLs) and the WINPR30.INI file.

These files can be read-only. The WINPR30.INI file should be read-only. There is no .INI setting that defines this 
directory, and the value is always set to the location of the WINPRS.EXE file.

User/Working Directory
The user/working directory contains user-specific files, e.g., saved project files, WINPR30U.INI and work files. The 
user must have full access rights to this directory.

The user/working directory is set by the working directory on the Premise icon in Windows.

If the working directory is the same as the application directory, the path will default to the user’s Premise directory, 
e.g., \WINDOWS\WESTWIN\Premise. The \WESTWIN\Premise directory is created off the user’s Windows directory 
by launching Premise.

Library Directory

The library directory contains all files that are related to the library list (e.g., license directory, library list files, 
CDVOLUME.INI and the P0000001 directory for hypertext link files). Network users can share the library directory 
by clicking the Library Directory button in the File Locations dialog box and choosing a path. This change is not 
effective until you restart Premise.

The library directory should have full access rights, and the BOOKS.DAT, BOOKS.IDX and CDVOLUME.INI files 
may be read-only.

The LibraryDir setting in the [SETTINGS] section of the WINPR30.INI or WINPR30U.INI file specifies the library 
directory, as shown in the following example:

[SETTINGS]

LibraryDir = X:\APPS\LIBRARY\

If this variable is not present, the library directory defaults to what is known as the normal location, e.g.,

X:\APPS\Premise\LIBRARY 
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Common Directory
The common directory contains files that are shared with other West applications. You can change this directory by 
clicking the Common Directory button in the File Locations dialog box and choosing a path. This change is not 
effective until you restart Premise. 

The CommonDir setting in the WINPR30.INI or WINPR30U.INI file specifies the common directory, as shown in the 
following example:

[SETTINGS]

CommonDir = X:\APPS\COMMON\ 

If this variable is not present, the common directory defaults to what is known as the normal location, e.g.,

X:\APPS\Premise\COMMON

This directory may have read-only access rights.

Public Directory
The public directory contains files that are shared by multiple users. The CTTEMP.DAT file is the only file in this 
directory. If users will be sharing notations files, they will need to share the same public directory. You can change this 
directory by clicking the Public Directory button in the File Locations dialog box and choosing a path. This change is 
not effective until you restart Premise. 

The PublicDir setting in the WINPR30.INI or WINPR30U.INI file specifies the public directory, as shown in the 
following example:

[SETTINGS]

PublicDir = X:\APPS\PUBLIC\

If this variable is not present, the public directory defaults to what is known as the normal location, e.g.,

X:\APPS\PremiseB\PUBLIC

This directory should have full access rights.
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Silent Installation
To run a basic silent installation for Premise 4.2.0, execute the following command line on the end user PC at the 
administrator installation point:

setup.exe /s /v“/qn TRANSFORMS=premise4.mst REBOOT=ReallySuppress”

By default, this will copy the software locally.

If you do not want the software to be copied locally, execute the following command line on the end user PC at the 
administrator installation point:

setup.exe /s  /v“/qn TRANSFORMS=premise4.mst SOFTWARE_REMOTE=1 REBOOT=ReallySuppress”

Note:  UNC or drive letter mapping can be used for the command line path to the setup.exe.

Silent Uninstallation
To silently uninstall Premise 4.2.0, execute the following command line on the end user PC:

MsiExec.exe /qn /x(383A78BE-629E-4195-BDD2-5D5026EFA1F1).

Note: Make sure that the MsiExec.exe program is in the path. (MsiExec.exe is likely in the C:\WINNT\system32 
directory on W2K and WXP systems, but it may be in the C:\Windows\System directory on older systems.)
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Chapter 3

Copying West CD-ROM
Libraries Data to a Hard Drive

Manually Copying Data
Following are the steps required for manually copying your West CD-ROM Libraries data to a hard 
drive. These instructions apply to both a stand-alone and a network environment. For assistance, call 
West Customer Technical Services at 1-800-888-9907.

Determining Hard Disk Availability and Requirements
The first step in copying the data to your hard drive is to determine how much hard disk space you 
have available and how much hard disk space your CD-ROM libraries require.

Windows 98 and Windows NT 4.0
In My Computer, choose Details from the View menu. The total size and the free space are listed for 
the hard disk drive and the CD-ROM drive.

Your available hard disk space must be greater than the space required by the CD-ROM disc.

Copying CD-ROM Files to the Hard Drive
The second step is to copy the CD-ROM files to your hard drive. You must create one subdirectory 
for each CD-ROM disc you are going to copy. These subdirectories must use the volume label from 
the CD-ROM disc.

For example, if you are planning to copy the Michigan Reporter (a two-disc library) and West’s 
Michigan Compiled Laws Annotated libraries, your subdirectory names might be WPC02009 or 
WPC02016.

Windows 98, 2000, Me, XP, and NT 4.0
1. In My Computer, double-click your hard drive, e.g., (C:). Choose New, Folder from the File 

menu. Type WESTCD and press Enter to create the WESTCD folder.

2. Double-click the WESTCD folder to move to the subdirectory.

3. Choose New, Folder from the File menu and type WPC02009. Press Enter to create the 
WPC02009 folder.

4. Insert your CD-ROM disc, e.g., Michigan Reporter, in the CD-ROM drive.

5. Double-click your CD-ROM drive. Select the contents of the disc by choosing Select All from the 
Edit menu.

6. Choose Copy from the Edit menu.
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7. Double-click the WESTCD folder that you created, and then double-click the WPC02009 folder.

8. Choose Paste from the Edit menu.

Repeat these steps for each disc, creating a unique folder (e.g., WPC02016 and WPC10616) for each disc.

Note: It may take 5 to 60 minutes to copy a West CD-ROM library, depending on the size of the disc(s) and your 
computer resources.

Editing the CDVOLUME.INI File
The third step is to configure the Premise tree structure by editing the CDVOLUME.INI file. The Premise tree structure 
allows Premise to access groups of CD-ROM books located in subdirectories under one volume name on a server or 
hard drive.

The CDVOLUME.INI file is located in the Library subdirectory containing your Premise software, e.g., 
C:|Premise\LIBRARY.

Open the CDVOLUME.INI file using any text editor, and edit the file as described below for your environment.

Stand-Alone Environment
Add the following line to the [drive] section:

[drive]

C:\WESTCD = tree

Network Environment
Map a drive to the subdirectory where you copied the West CD-ROM discs, as in the following examples:

Novell Netware

MAP E: = SERVERNAME\VOLUMENAME:\WESTCD

Windows NT network

NET USE E:\\SERVERNAME\SHAREDRESOURCENAME

Banyan Vines network

SETDRIVE E:ASICS@WLC@WEST/ROOT:WESTCD

Add the following line to the [drive] section:

[drive]

E = tree

You can use a universal naming convention to save a drive letter mapping, as in the following examples:
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Novell NetWare

Add the following line to the [drive] section:

[drive]

\\SERVERNAME\VOLUMENAME\WESTCD = tree

Windows NT, Windows for Workgroups and LANtastic networks

Add the following line to the [drive] section:

[drive]

\\SERVERNAME\SHAREDRESOURCENAME = tree

Note: In the Windows for Workgroups network environment, Premise will not recognize the libraries on the 
server’s hard drive because the server cannot define its own directories as shareable. If you are running 
Premise on the server, you must create a CDVOLUME.INI file in each user working directory, e.g., 
C:\WINDOWS\WESTWIN\Premise, to locate the discs. Create the file and add the following line in the 
[drive] section:
[drive]
C:\WESTCD = tree

Installing CD-ROM Books
Open Premise and install the CD-ROM books from your hard drive to the Premise Library. 

Copying West CD-ROM Libraries Update Discs to the Hard Drive
When you receive your West CD-ROM Libraries update discs, you need to delete the old data from your hard drive 
and copy the data from the new disc(s) to your hard drive.

Complete the following steps each time you receive an update disc:

■ Determine hard disk availability and requirements

■ Copy CD-ROM files to the hard drive

■ Edit the CDVOLUME.INI file

■ Install the CD-ROM books

Automatically Copying Data in a Stand-Alone Environment
The following steps describe how to automatically copy your West CD-ROM Libraries data to your hard drive if you 
are running Premise in a stand-alone environment. For assistance, call West Customer Technical Support at 
1-800-888-9907.

If you are running Premise in a network environment, automatic installation is not available. Also, if you are copying 
a large number of books, the Library list is easier to manage with the Premise tree structure.

Determining Hard Disk Availability and Requirements
The first step in copying the data to your hard drive is to determine how much hard disk space you have available and 
how much hard disk space your CD-ROM libraries require.
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Windows 98, 2000, Me, XP, and NT 4.0
In My Computer, choose Details from the View menu. The total size and free space are listed for the hard disk drive 
and the CD-ROM drive.

Your available hard disk space must be greater than the space required by the CD-ROM disc.

Copying CD-ROM Files to the Hard Drive
The second step is to copy the CD-ROM files to your hard drive.

1. Start Premise.

2. Inset your CD-ROM disc, e.g., Michigan Reporter, in the CD-ROM drive.

3. Choose Library Maintenance, Install CD-ROM Book from the File menu. The Install CD-ROM Book dialog box 
is displayed:

 Install CD-ROM Book dialog box

4. Select the disc(s) you want to copy to your hard drive. Select the Also Copy to Hard Drive check box and then 
click Install.

If you have more than one CD-ROM disc to install, click Install All.

Note: It may take 5 to 60 minutes to copy a West CD-ROM library, depending on the size of the disc(s) and your 
computer resources.

5. When the installation is complete, a dialog box containing a copyright message and a description of the contents 
of the disc is displayed. Click OK.

The CD-ROM book(s) are installed in the Library subdirectory containing your Premise software, e.g., 
C:\Premise\LIBRARY.

Editing the CDVOLUME.INI File
The third step is to edit the CDVOLUME.INI file, which will allow Premise to access the CD-ROM books on your 
hard drive.

The CDVOLUME.INI file is located in the Library subdirectory containing your Premise software, e.g., 
C:\Premise\LIBRARY.

Open the CDVOLUME.INI file using any text editor, and add the following line to the [drive] section:

[drive]

C:\Premise\LIBRARY\WPC06319 = local
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Add a line for each book (WPC folder) that was copied to your hard drive.

Note: If you need to reinstall CD-ROM books from your hard drive to your Premise Library, the books will be 
listed in the Install CD-ROM Book dialog box in the same order in which you entered them in the 
CDVOLUME.INI file. Use this order to identify your books if the full path of the books is not visible in the 
dialog box.

Copying West CD-ROM Libraries Update Discs to the Hard Drive
When you receive your West CD-ROM Libraries update discs, you need to delete the old data from your hard drive 
and copy the data from the new disc(s) to your hard drive.

Complete the following steps each time you receive an update disc:

■ Determine hard disk availability and requirements

■ Copy CD-ROM files to the hard drive

■ Edit the CDVOLUME.INI file
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Chapter 4

Maintaining Your Library

Overview
You will receive periodic updates to your West CD-ROM Libraries. It is necessary to install these 
books (West CD’s) immediately. This will ensure access to the most up-to-date information.

This chapter explains how to

■ automatically install new and update books (West CD’s) 

■  remove books from the Library 

■  select the order of books in the Library

■  update license keys

Installing New and Update Books (West CD’s)
Each disc in your library must be installed into the Library List before you can browse and search the 
books. By installing books, you are adding their titles to the Library and copying link files to allow 
jumping from text in one disc to text in another disc. You are not copying all the data to your hard 
drive.

Each republished CD-ROM disc you receive must also be installed into the Library before you 
conduct research. When you install an update disc, the titles and identification numbers from the 
previous book are automatically removed from the Library and replaced by the new titles and 
identification numbers.

Automatically Installing Books (West CD’s) 
Premise allows you to automatically install books (West CD’s).

To automatically install new and update books (West CD’s), insert the disc into your CD-ROM drive. 
A dialog box similar to the one on the following page is displayed:
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New Premise Disc dialog box

Copy CD to hard drive and install
If you select Copy CD to hard drive and install (default), books (West CD’s) will automatically be installed to your 
hard drive. A dialog box similar to the one shown below is displayed:

Install for use off the CD-ROM drive
If you select Install for use off the CD-ROM drive, Premise is automatically launched. The Install CD-ROM Book 
dialog box is displayed. Click Install or Install All to install the West CD.

Select the location
where you want the

Premise data
copied.

If you select this
check box, Premise
data will always be
copied to the same

location.

Select Perform this
action every time a

disc is inserted to
always install West
CD’s according to

your installation
choice.
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Do nothing
If you select Do nothing, you must launch Premise every time you install a book (West CD).

To install new and update books (West CD’s) from Premise, complete the following steps:

1. Insert a compact disc from your West CD-ROM library into the CD-ROM drive.

2. Choose Library Maintenance, Install CD-ROM Book from the File menu. A dialog box similar to the one shown 
below is displayed:

 

 Install CD-ROM Book dialog box

3. Select the disc(s) you want to install into your Library, e.g., WPC01531, and then click Install.

If you have more than one CD-ROM disc to install, click Install All. Premise will automatically install all the discs 
listed.

4. When the installation is complete, a dialog box containing a copyright message and a description of the contents 
of the disc is displayed. Click OK. All the books on the disc will be listed in your Library.

5. To install additional books, click the Install CD button or choose Library Maintenance, Install CD-ROM Book 
from the File menu. Repeat steps 4 and 5 until you have installed all the discs in your West CD-ROM Libraries. 

Installing Books from Magnetic Media
Installing a magnetic book means copying the list of books from the hard disk drive or network directory to the Premise 
Library. Installing a magnetic book does not involve copying all the data from one location to another. The installation 
adds the book titles to the Library.

To install new and update books from a floppy disk, hard disk drive or network drive, complete the following steps:

1. Choose Library Maintenance, Install Magnetic Book from the File menu.

A dialog box similar to the one shown below is displayed:

 

 Install Magnetic Book dialog box
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2. In the Filename text box, type the drive and path name of the installation file of the book you want to install, or 
select the file and directory in the list boxes. Click OK.

3. For example, if the book you want to install is on a floppy disk in drive A, type a:\install and then click OK.

Note: The installation file contains the necessary information for installing the book into the Premise Library.

If you have more than one magnetic book to install, select the Multiple Book Installation check box and then click 
OK. You will automatically be returned to the Install CD-ROM Book dialog box after each book is installed, allowing 
you to change disks or directories and install additional books quickly.

Note: If you are installing multiple books, click Done in the Install Magnetic Book dialog box when you are 
finished installing.

4. When the installation is complete, a dialog box containing a copyright message and the contents of the book is 
displayed. Click OK.

License Information
Certain books require a license key to access the data on the disc. License keys are needed to increase the number of 
concurrent users for networked discs. If a key is required, it is sent to you on a card with your CD-ROM discs. You 
need to enter the key only once to make the data available.

Entering a License Key
If you need a license key to access a book that has already been installed into your Library, you must enter the license 
key before accessing the book.

Note: If you are changing the number of licenses for a book, you may need a new license key.

To enter a license key, complete the following steps:

1. Choose Library Maintenance, Enter License Key from the File menu.

 A dialog box similar to the one shown below is displayed:

 

 License Key dialog box

Note: The license directory must point to one location on the network for all Premise users in order to comply 
with your license contract.

2. Type the license key in the Please enter a license key text box and click OK.

You can now access the book from the Library.



Removing a Book from the Library

Premise Technical Reference Manual 23

Accessing License Information
From the Help menu, choose License Information.

A dialog box similar to the one shown below is displayed:

 

 License Information dialog box

The License Information dialog box displays the following information:

■  customer ID

■  list of book titles

■  total number of licenses

■  licenses in use

■  number of times access was denied to the book

■  demo end date (date license key will expire on a demo book)

Removing a Book from the Library
When you install books from an update CD-ROM disc, the titles and identification numbers from the previous book 
are automatically replaced by the new titles and identification numbers. However, there may be occasions when you 
need to remove a book from the Library. 

To remove a book from the Library, complete the following steps:

1. From the Library, select the book(s) you want to remove.

Note: If you want to remove multiple books, hold down the Control key while selecting the books.

2. Choose Remove Book, Library Maintenance from the File menu.

3. Click Yes to remove the book(s) from your Library.
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Selecting Library Order
Premise allows you to select the order in which your books are displayed in the Library. Books can be listed in any of 
the following ways:

■ By Book Name, e.g., IL-LEG-1994. Each book in your West CD-ROM Libraries has a unique, abbreviated book 
name that is displayed in the Library. This is the default list order.

■ By Title, e.g., Illinois Sess. Laws 1994.The books in the Library are displayed alphabetically by title.

■ By Source, e.g., WPC10312.The books in the Library are displayed numerically in ascending order by the source 
number, which is a unique identification number associated with each disc.

To select the list order of the books in your Library, complete one of the following steps:

1. Choose Reorder by, Library Maintenance from the File menu. Choose a list order from the pop-up menu, e.g., 
Book Name, Title or Source.

2. Click the Book Name, Title or Source button in the Library window to reorder your Library.

Note: You can also reorder the Library by choosing the buttons (hotspots) above the Library list. Choosing a 
button for book name, title or source will reorder the Library by that category.

Updating Books on a Local Area Network
You must install each new and republished CD-ROM disc you receive before you can conduct research on the new 
data. This section explains how to install these discs into your Library on a LAN using redirection.

Editing the CDVOLUME.INI File
Each CD-ROM disc that you receive has been assigned an identification number (e.g., WPC01304). You must update 
the identification number(s) in your CDVOLUME.INI file to reflect the numbers on any new or update CD-ROM discs 
that you receive. You must also specify a location for any new discs. You can make changes to the CDVOLUME.INI 
file using any text editor.

Note: You need to edit the CDVOLUME.INI file when updating your CD-ROM books only if you are using 
dynamic drive mapping or redirection. 
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 An example of the CDVOLUME.INI file is shown below.

Note: Your actual CDVOLUME.INI file may look slightly different from the example below, depending on your 
CD-ROM sharing software.

[drive]

J=redirectable

[volume]

WPC00057 = \\SERVER\WPC00057

WPC00058 = \\SERVER\\WPC00058

WPC00059 = \\SERVER\\WPC00059

WPC00060 = \\SERVER\\WPC00060

WPC01301 = \\SERVER\WPC01301

WPC01302 = \\SERVER\WPC01302

Installing New or Update Books in Premise
After you update the CDVOLUME.INI file with any new or update CD-ROM volumes you need to install the books 
so that they appear in the Library. To install new or update books on a local area network, complete the following 
steps:

1. Choose Library Maintenance, Install CD-ROM Book from the File menu.

A dialog box similar to the one shown below is displayed:

 

 Install CD-ROM Book dialog box

2. Select the disc you want to install, e.g., WPC01531, and then click Install.

3. A copyright message is displayed. Click OK.

Repeat the above steps for each new disc.
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Chapter 5

Changing Preferences

Overview
This chapter explains how you can modify Premise at your workstation to meet your specific needs. 

Choose Preferences, Setup from the File menu to customize your Premise user interface options.

A dialog box similar to the one shown below is displayed:

 

 Preferences dialog box

The options for Workstation, Search, Client Validation, and Option Configuration appear in a dialog 
box when you click the corresponding button. The screen display and text display settings are 
displayed automatically in the dialog box when you choose the Preferences command.

The Preferences options are described in the following table.
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Changing Text and Screen Display Settings
Your text and screen display settings can be changed in the Preferences dialog box, accessed by choosing Preferences, 
Setup from the file menu.

Text Display Settings
Note: The user-defined display text settings can be used only in books where there are no publisher-defined 

settings.

Note: If your books have predefined publisher fonts and you would like to view the text in a larger or smaller 
font, use the enlarge/reduce features. The enlarge/reduce features are available in document text windows 
by using a menu activated by clicking the right mouse button or by selecting the + or  - keys on the keyboard.

Category Options

Screen and Text Display Settings ■ Display a summary of time spent on 
the current project

■ Maximize each new window

■ Show balloon help

■ Display inline images

■ Set display settings (e.g., font, size, 
color) for normal text, highlighted 
terms, hypertext references, non-
proportional text, Star Paging and 
best selections

Workstation ■ First window displayed when you 
start Premise

■ Window displayed upon opening a 
new book

Search Browsing display in documents 
retrieved by a query

Client Validation West-supplied client validation

Option Configuration Premise options that can be controlled 
by Administrator



Changing Text and Screen Display Settings

Premise Technical Reference Manual 29

You can change the attributes for six kinds of text in the Text Type list box:

■ Normal text (the text displayed in all of the Premise screens)

■ Highlighted terms (the search terms in your search results)

■ Hypertext references (referenced information, such as cited cases, that you can jump to)

■ Non-proportional text (tabular information)

■ Star Paging (specific pages from the print publication)

■ Best section (most relevant portion of a Natural Language search)

Complete the following steps to change text display settings:

1. Select the type of text you want to change in the Text Type list box.

2. To change the font, select the font from the Font list box.

3. The font selected for Normal text will also be used for the highlighted terms, hypertext references, Star Paging and 
best features.

4. To change the type size, select the type size you want in the Size list box.

5. The size selected for Normal text will also be used for the highlighted terms, hypertext references, Star Paging and 
best features.

6. To change the color of the text, select the color you want from the Color drop-down list box.

7. Repeat steps 1 through 4 for each type of text that you want to change. As you make changes, an example of the 
text with the current attribute settings is displayed in the Sample box.

8. After adjusting your display settings attributes in the Preferences dialog box, click OK to save the new settings.

Screen Display
The following screen display options are available in the upper-left corner of the Preferences dialog box. An option is 
selected when the corresponding box has an X in it.

■ Project Time Summary. When you close a project, select this option to display a dialog box that tells you the 
amount of time spent on the current project.

■ Maximize on Open. Select this option to enlarge windows when they are opened.

■ Show Balloon Help. Select this option to turn on balloon help where available. 

■ Display Inline Images. Select this option to display images in context in your Premise books.

■ Access via westlaw.com. Select this option if you want to access Westlaw via westlaw.com.
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Changing Workstation Options
You can view the Workstation Preferences dialog box by clicking Workstation in the Preferences dialog box.
A dialog box similar to the one shown below is displayed:

 

 Workstation Preferences dialog box

The Workstation Preferences dialog box allows you to select the first window that is displayed when you start Premise 
and the first dialog box that is displayed when you open a new book.

First Displayed Window
To change the first window displayed when you start Premise, select one of the four listed options:

■ Instruction Window. This window gives you options to start a new research project, open an existing project or 
install a new book. Instruction Window is the default setting.

■ Start a New Project. Each time you start Premise, a new research project automatically starts and the Library 
window is displayed.

■ Open an Existing Project. Each time you start Premise, the Open Project dialog box is displayed. You can select 
one of your saved research projects and resume your research.

■ Search Book(s). You can pre-select books that you regularly search and automatically go to the Search dialog box 
for those books.

Upon Opening a New Book
To select the default activity when you open a new book, select one of the four listed options:

■ Search Book. The Search dialog box, in which you can enter a query, is displayed. Search Book is the default 
setting.

■ View Scope/First Page. The first page of text in the book is displayed.

■ View Document List. The list of all documents contained in the book is displayed.

■ Retrieve Document. The Retrieve Document dialog box, in which you can enter a specific citation and move 
directly to the case, is displayed.

After you have chosen your workstation preferences, click Done; click OK to save your settings.



Changing Search Options

Premise Technical Reference Manual 31

Changing Search Options
Click Search in the Preferences dialog box to display the Search Preferences dialog box, as shown below:

 

 Search Preferences dialog box

The Search Preferences dialog box allows you to select which page is displayed when you are browsing your search 
results by search term.

To select the page to be displayed when browsing by search term, select one of the following options:

■ First Page. The first page of the next document is displayed, even though that page may not contain any search 
terms. First Page is the default setting.

■ First Term Page. The first page containing a search term in the document is displayed. The first page of a document 
is displayed only if it contains search terms.

Setting Up Client Validation
The Client Validation program keeps track of how much research was done for each client. See Chapter 8, “Client 
Validation,” for more information on client validation.

Controlling Option Configuration
The administrator can control user access to many Premise options with an administrator password. The Premise 
options can be turned on, controlled by a password, or turned off. See the Premise 4.2.0 Administrator Guide for more 
information on controlling user access to Premise features.

Click Option Configuration in the Preferences dialog box to display the Option Configuration dialog box, as shown 
on the following page:
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Option Configuration dialog box

The Premise options that can be controlled include the following:

■ Project items in the File menu

■ Setup, including Preferences and Toolbars 

■ Library Maintenance, including CD-ROM book maintenance items in the File menu

■ Notebook items in the Edit menu

■ Search items in the Search menu

■ Westlaw access and Westlaw services in the Westlaw menu

■ Customer Assistance information in the Help menu

■ File Locations information in the Help menu

■ Log, including viewing user log information in the File menu

■ Time out interval, including time limits for Premise research

Click Details
for a

description of
the option.
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Chapter 6

Setting Up Your Printer

Overview
This chapter describes how to select your printer and set up printing options for Premise if you want 
to use a printer other than the one selected in Control Panel in Windows. 

Premise uses the same print drivers as your Windows software. Therefore, if you can print from other 
Windows applications that use Windows print drivers, you should be able to print from Premise. 

Setting Up Your Printer
Choose Printer Setup from the File menu. 

A dialog box similar to the one shown below is displayed:

 -

 Print Setup dialog box

To select a printer other than the default printer, complete the following steps:

1. Select a printer from the Name drop-down list.

The drop-down list displays all the printers available to you.
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All the paper sizes and tray locations that are available with your selected printer are listed in the Size and Source drop-
down lists. 

To change your paper size or source, complete the following steps:

2. Select your paper size from the Size drop-down list.

3. Select the appropriate paper tray from the Source drop-down list.

4. Click OK.

Note: The printer settings you select in the Print Setup dialog box become the Premise default settings, even if the 
settings are different from the Windows Control Panel settings.



Premise Technical Reference Manual 35

 Chapter 7

Setting Up Communications

Overview
This chapter explains

■ how to set up general communications

■ how to specify sign-on options

■ how to modify advanced communications

■ how to set up automatic entry of your Westlaw password

Using westlaw.com to Access Westlaw
If you are using westlaw.com to access Westlaw, you do not have to set up communications. 
Accessing Westlaw via westlaw.com provides the best way to use Westlaw for your legal research. 
With Premise 4.2.0, the default setting for accessing Westlaw is westlaw.com.

Note: The remainder of this chapter is for users who do not want to use westlaw.com to access 
Westlaw.
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Setting Up General Communications
If you do not want to access Westlaw via westlaw.com, complete the following steps:

1. Choose Setup from the File menu in Premise. Then click Setup, Preferences.

The following dialog box is displayed:

Preferences dialog box

2. Clear the check box next to Access via westlaw.com if you do not want to access Westlaw using westlaw.com

General Communications
Complete the following steps to set up your general communications:

1. Choose Communications Setup from the Westlaw menu.

A dialog box similar to the one shown below is displayed:
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 Communications Setup dialog box

2. Select the communications device from the Communications Device drop-down list.

Premise is compatible with the following communications devices:

■ Eicon X.25

■ Internet TCP/IP

■ Local Modem

Note: Internet TCP/IP and Eicon X.25 communications devices are discussed later in this section.

3. Select your modem from the Data Modem drop-down list.

Modem Properties
Click Modem Properties on the Communications Setup-General dialog box to set up our modem. You can select the 
communications port of your modem, adjust the speaker volume of your modem, select the maximum speed of your 
modem, or choose to connect only at the maximum speed of your modem.

Dialing Properties
Click Dialing Properties on the Communications Setup-General dialog box if you want to access Westlaw from a 
different location than what you have set up. Complete the appropriate location and dialing information.

Phone Numbers
If you are using a local modem and want to verify or retrieve phone numbers for accessing Westlaw, click Phone 
Numbers on the Communications Setup-General dialog box. The current access phone numbers are shown in the 
dialog box. Click Next to edit or add a phone number. Follow the instructions on the next dialog boxes and click Finish 
after you verify the new access phone numbers.

Internet TCP/IP Communications Device
If you are using the Internet TCP/IP communications device, choose Communications Setup from the Westlaw menu. 
A dialog box similar to the one shown on the following page is displayed.
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Communications Setup dialog box

Verify the remove IP address. If you want to replace the existing sign-on options with Internet TCP/IP, select the check 
box at the bottom of the dialog box.

Eicon X.25 Communications Device
If you are using the Eicon X.25 communications device, choose Communications Setup from the Westlaw menu. A 
dialog box similar to the one shown below is displayed:

Communications Setup dialog box

Verify that the information is correct. If you want to replace the existing sign-on options with Eicon X.25 Gateway, 
select the check box at the bottom of the dialog box.
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Specifying Sign-On Options
Complete the following steps to change your sign-on options for accessing Westlaw:

1. Choose Communications Setup from the Westlaw menu.

2. Click the Sign-On Options tab.

A dialog box similar to the one shown below is displayed:

Communications Setup—Sign-On Options dialog box

3. To add a sign-on option to access Westlaw, select the option in the Available Sign-On Options list box. Then click 
Add. The new sign-on option is now displayed in the Current Sign-On Options list box.

4. To remove a sign-on option from the Current Sign-On Options list box, select the option to be removed, then click 
Remove. Removed sign-on options remain the Available Sign-On Options list box and can be reselected later.

5. To remove all the sign-on options from the Current Sign-On Options list box, click Remove All.

Modifying Advanced Access Setup
The Advanced Access option allows you to modify, delete, copy, create or rename Westlaw and user-defined access 
programs.

1. Choose Communications Setup from the Westlaw menu.

2. Click the Advanced Access tab.

 A dialog box similar to the one shown on the following page is displayed.
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Communications Setup—Advanced Access dialog box

The available sign-on options are displayed. The buttons on the right side of the dialog box are used to modify the 
sign-on options and are recommended for advanced users.

Properties
To change your device or network settings, select the appropriate sign-on option, then click Properties. The current 
settings for the communications device, communications driver, service script, and data modem are displayed as shown 
in the following dialog box. Select the appropriate communications device to change any of its settings.

 

Click the Network tab to set up the telephone number, network address, and network script for the sign-on option. A 
dialog box similar to the one shown below is displayed:

Properties—Network dialog box
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Type the telephone number, including area code; select the country; type the network address; and select the network 
script in this dialog box.

New
To add a new program to the sign-on options, click New in the Communications Setup-Advanced Access dialog box. 
Type a new program name in the Program Name text box, then set up the appropriate device and network settings.

Copy
To copy settings from a sign-on option to another network, select the network you want to copy from. Click Copy in 
the Communications Setup-Advanced Access dialog box. Type the new sign-on option (the network you want to copy 
to) in the To text box.

Scripts
To edit, copy, or create a new communications script, click Scripts in the Communications Setup-Advanced Access 
dialog box. A dialog box similar to the one shown below is displayed:

Scripts dialog box

Properties
If you want to edit an existing script, select the script you want to edit from the Scripts list box, e.g., hangup, then click 
Properties. A dialog box similar to the one shown on the following page is displayed:
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Script Properties dialog box

Copy Scripts
If you want to copy a script, select the script you want to copy from, e.g., hangup, in the Scripts list box, then click 
Copy. A dialog box similar to the one shown below is displayed:

Copy dialog box

New Script
If you wan to add a new script, click New in the Scripts dialog box. A dialog box similar to the one shown below is 
displayed:

New Script dialog box

Type the new script name and click OK. A dialog box is displayed allowing you to edit the script. The new script is 
then added to your list of scripts.
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Chapter 8

Client Validation

Overview
When you access Westlaw with Premise, you must enter a password and client identifier. Premise 
contains an optional feature that enables you to have greater control over billable time. The Premise 
Client Validation program helps you keep track of how much research was done for each client. 

You can use either the West-supplied Client Validation program or one that you customize. This 
chapter explains how to set up the West-supplied Client Validation program and how to customize 
your own.

Accessing Premise with Administrative Privileges
The Client Validation setup is usually performed by someone who controls the access options or 
rights to Premise. The ability to set up Client Validation is available only by accessing Premise with 
administrative privileges.

To enable Client Validation privileges, complete the following steps before setting up a Client 
Validation program within Premise:

1. Open the WINPR30.INI file in a text editor such as Notepad.

2. Go to the [Preferences] section and change the CVRights flag from 0 to 1.

3. Save the change and exit the text editor.

4. Start Premise.

Note: After setting up Client Validation, open the WINPR30.INI file and reset the CVRights flag 
in the [Preferences] section to 0.

Creating the Client Validation Data File
When using the West-supplied Client Validation program, Premise compares the client identifier 
entered by a user against the list of valid identifiers in the Client Validation data file.

To set up Client Validation, you must first create the data or text file by using a text file editor, such 
as Windows Notepad. You can also create the file in a word processor if you save it as a text file.

The data file is simply a list of valid client identifiers, each followed by a carriage return. 
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A sample data file created in Notepad is shown below:

 

 Sample Client Validation data file

Note: It is important to remember the name and path of the file, e.g., CLIENT.DAT, as this information must be 
entered in the Client Validation Setup dialog box within Premise.

Enabling West-Supplied Client Validation
To enable Client Validation, complete the following steps:

1. Choose Setup, Preferences from the File menu. The Preferences dialog box is displayed, as shown below:

 

 Preferences dialog box



Enabling West-Supplied Client Validation

Premise Technical Reference Manual 45

2. Click Client Validation. The Client Validation Setup dialog box is displayed, as shown below:

 

 Client Validation Setup dialog box

3.  Select client.cli from the Validation Program drop-down list, as shown below:

 

 Client Validation Setup dialog box

4. Click Setup. The following dialog box is displayed:

 

 Client Validation Setup dialog box

5. Enter the numeric position at which you want Client Validation to start checking client IDs in the Validation 
Range Start text box. The default value is 1.

For example, for the format XXX-client name, you would type 5 in the Start text box. Users enter three initials, 
followed by a hyphen (in the fourth position) and then the beginning of the client ID in the fifth position.

The Client Validation program ignores all characters before the position specified by the number in the Start text box.
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6. Specify the number of client ID characters you want to be validated in the Length text box. The maximum is 32.

Note: The sum of the numbers you enter in the Start text box and the Length text box must be less than or equal 
to 33.

7. Enter the format in which you want users to enter their client IDs in the Format Description text box. 

8. Enter the name of the file that contains the list of valid client IDs in the Data File text box, e.g., CLIENT.DAT. 
The file must be in ASCII text format. You can click Browse to see a list of data files.

9. Click OK to close the Client Validation Setup dialog box.

10. Click OK to exit Client Validation setup.
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Chapter 9

Troubleshooting Premise

Overview
This chapter describes some error messages you might receive when using Premise and explains steps 
you can take to solve them. Access http://west.thomson.com/support/ for a detailed list of error 
messages, or call West Customer Technical Support at 1-800-888-9907.

The following Premise errors are discussed in this chapter:

■ Library list error

■ Unable to locate disc

■ Library list becomes unreadable

■ General protection fault errors

■ Problems installing Premise

■ CD-ROM drive problems

■ Westlaw error messages

Library List Error
This error message usually occurs when you are trying to access or install a book. This error occurs 
when Premise is unable to interpret the file that stores the information Premise is attempting to 
retrieve.

Possible Solutions
■ Delete the book from the Library and then reinstall the book. 

■ The files containing the Library may be corrupt. Delete the Library files, BOOKS.DAT and 
BOOKS.IDX, from the library directory where Premise is installed, e.g., C:\Premise\LIBRARY. 
You can use Windows File Manager to delete the files. 

Note: If you delete the Library files, all books will need to be reinstalled to the Library.

■ A user may not have network rights to a location where Premise is trying to create a file. Have a 
person with full network rights sign onto the network at the terminal where the error occurs.
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Unable to Locate Disc
This error message occurs if the disc has not been installed or the Premise files containing the disc information have 
been improperly updated or corrupted.

Possible Solutions
■ Verify that the correct disc is in the CD-ROM drive. Compare the WPC number on the disc with the WPC number 

on the Library.

■ If you have an external CD-ROM drive, turn it off and on and then reboot your computer. If you have an internal 
CD-ROM drive, turn your computer off and on.

■ Verify that you can access the CD-ROM drive from your operating system.

■ If the summary of the disc contents is unreadable or does not appear, or the disc cannot be accessed, try cleaning 
the disc with a soft, lint-free cloth. Reboot the computer and try again.

■ The CD-ROM drive may be mapped incorrectly. Make sure the WPC number on the disc matches the one in the 
VOLUME section of the CDVOLUME.INI file, which is located in the \Premise\LIBRARY directory. If the WPC 
numbers do not match, edit the CDVOLUME.INI file to show the new WPC number.

■ Install the current CD-ROM disc. If the book is listed in the Library in Premise, remove the book and try 
reinstalling it.

■ Remove all books with the WPC number of the problem disc from the Library. Then try reinstalling the books. 

■ Try cleaning the disc with a soft, lint-free cloth from the center of the disc to the edge in a straight line. Try 
reinstalling the disc.

■ If the disc has a scratch on it, call West Customer Technical Support at 1-800-888-9907.

■ If you are running Microsoft Extensions, make sure the MSCDEX.EXE file loaded in your AUTOEXEC.BAT file 
is not loaded into upper memory.

■ Premise requires CD-ROM drives to meet ISO9660 standards and to have a 660MB drive capacity. Refer to the 
documentation for your CD-ROM drive to verify its drive capacity and technical specifications.

General Protection Fault Errors (GPFs)
General protection fault errors (GPFs) can happen while you are executing various commands in Premise, including 
printing and searching.

Possible Solutions
Always try general Windows troubleshooting procedures when experiencing problems. The following solutions may 
help solve specific GPFs in Premise. 

Printing
■ Verify that the proper print driver is being used in the Printers section of the Windows Control Panel. If another 

print driver has been installed, you can select it in Premise by choosing Print Setup from the File menu.

■ Print in a different format in Premise.
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Searching 
Premise may freeze if multiple files or programs are open at the same time. Close any unnecessary applications to free 
more memory for Premise to operate.

Problems Installing Premise
Sometimes problems occur while installing Premise. Premise may be conflicting with another software package you 
have running on your computer, or Premise may encounter a problem when trying to detect your modem.

Possible Solutions
■ Exit all software and reboot your computer. Make sure you close all applications before starting the Premise 

installation.

■ If the installation program locked while trying to auto-detect your modem, select the box to manually configure 
your modem settings in the Communications Setup dialog box in the installation program. 

■ Delete the WINPR30.INI file and then reinstall Premise as an upgrade.

CD-ROM Drive Problems
Possible error messages indicating a problem with your CD-ROM drive include the following:

■ Cannot open book

■ Reinsert disc

■ Invalid drive specification

Possible Solutions
■ If you are using an internal CD-ROM drive, close all applications and turn the computer off. Look for error 

messages that appear when the computer is booting up.

■ Make sure all lights have stopped flashing on the CD-ROM drive before you select the disc.

■ Verify that the source number (WPC number) in the Premise Library is the same as the WPC number on the disc.

■ Try reinstalling the book to the Library. From the File menu, choose Library Maintenance, Install CD-ROM Book 
to install the book. Click Install even if the status shows it as installed or no WPC number is displayed in the dialog 
box. Click OK when the book description appears. Try to reaccess the book.

■ Verify that you can access the CD-ROM drive from a DOS prompt. Change to the drive letter of the CD-ROM 
drive (e.g., D:), and type type WPC#.ABS. (The WPC# is the identification number found on the CD-ROM disc, 
e.g., WPC00123.) If a summary of the disc contents appears, reaccess Premise and try to reaccess the book.

■ If the summary of the disc contents is unreadable or does not appear, or the disc cannot be accessed, try cleaning 
the disc with a soft, lint-free cloth. Reboot the computer and try again.

■ Try a different disc to determine if the problem is with the one disc or all discs. 

Modem Unable to Connect, Prompt Not Received
These messages indicate that your modem can dial a phone number but the call is not answered.
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Possible Problems
■ You may be experiencing temporary line interference.

■ The access phone number in your Premise communications setup may be incorrect.

■ You may need to use a dialing prefix (8 or 9) to dial out of the building. 

■ If you entered a dialing prefix to disable call waiting, the dialing prefix may be incorrect for your calling area.

■ Your modem may be tone dialing on a pulse dial line.

Possible Solutions
■ If your current communications setup has worked before, reset your modem. If you have an internal modem, 

reboot your computer. Restart Premise and try to access Westlaw again using a different sign-on option.

■ Access at a slower speed to avoid line interference. 

■ If you suspect there is a problem with a phone number, dial the number from a telephone and verify that you hear 
a modem tone. 

■ Verify that the phone numbers in your communications setup are correct. Call 1-800-WEST-NIS 
(1-800-937-8647) to receive current access phone numbers for your calling area. Choose Communications Setup 
from the Westlaw menu. Click General Setup and verify that the phone numbers in the Phone Number text box 
are correct for each network and its corresponding modem speed. The phone numbers in the text box should not 
include dashes, slashes or parentheses. Include the area code only if you would normally dial it when making a 
telephone call. 

■ You may need to insert a dialing prefix into your Premise communications setup. If you normally use a prefix, e.g., 
8 or 9, to reach an outside line, make sure one is listed in the Dialing Prefix text box in the General 
Communications Setup dialog box. To do this, choose Communications Setup from the Westlaw menu. Click 
General Setup, and type the desired dialing prefix in the Dialing Prefix text box. After clicking OK, click Yes to 
apply the new dialing prefix to all sign-on options. Reset your modem and try to access Westlaw again.

If you are unsure whether you need to use a dialing prefix, plug a phone into the wall jack in place of the modem and 
dial a phone number. Don’t forget to reconnect the phone line to the modem.

■ You may need to set your modem for pulse dialing instead of tone dialing. Pulse dialing makes clicking sounds 
instead of tones when you dial. Choose Communications Setup from the Westlaw menu. Click General Setup, and 
type a capital letter P in the Dialing Prefix text box. After clicking OK, click Yes to apply the new dialing prefix 
to all sign-on options. Reset your modem and try to access Westlaw again. This instructs your modem to use pulse 
dialing. If you are not sure whether your telephone line is set up for pulse or tone dialing, try adding the capital 
letter P in the prefix section; all telephone lines can support pulse dialing.

■ If you have call waiting and you added a prefix to the telephone number to disable it during your Westlaw sessions, 
delete the prefix and attempt to access Westlaw again. 

There Are No Licenses Available or Cannot Find License File
These error messages occur if using Novell Client 4.8X and more than one workstation is trying to access the same 
Premise book at the same time no matter how many licenses you have.

Possible Solutions
■ This problem has been fixed in Novell Client 4.83 Support Pack 1. Update to NWFS.SYS Novell build dated 

March 7, 2002 or later. 




	Contents
	Chapter 1
	Introduction .........................................................................................................1
	Overview .......................................................................................................................................1
	Equipment Requirements ............................................................................................................2
	Customer Support........................................................................................................................ 3

	Chapter 2
	Configuring Premise on a Local Area Network .................................................5
	Overview .......................................................................................................................................5
	LAN Configuration ........................................................................................................................5
	File Locations................................................................................................................................. 9
	Silent Installation ........................................................................................................................11

	Chapter 3
	Copying West CD-ROM Libraries Data to a Hard Drive.................................. 13
	Manually Copying Data ..............................................................................................................13
	Automatically Copying Data in a Stand-Alone Environment ..................................................15

	Chapter 4
	Maintaining Your Library .................................................................................19
	Overview ......................................................................................................................................19
	Installing New and Update Books (West CD’s) ......................................................................... 19
	License Information .....................................................................................................................22
	Removing a Book from the Library............................................................................................ 23
	Selecting Library Order............................................................................................................... 24
	Updating Books on a Local Area Network ................................................................................24

	Chapter 5
	Changing Preferences .......................................................................................27
	Overview .....................................................................................................................................27
	Changing Text and Screen Display Settings .............................................................................28
	Changing Workstation Options 30
	Changing Search Options ...........................................................................................................31
	Setting Up Client Validation ....................................................................................................... 31
	Controlling Option Configuration ..............................................................................................31

	Chapter 6 Setting Up Your Printer ..........................................................................................................33
	Overview 33
	Setting Up Your Printer 33

	Chapter 7
	Setting Up Communications ..................................................................................................35
	Overview 35
	Setting Up General Communications 36
	Specifying Sign-On Options 39
	Modifying Advanced Access Setup 39

	Chapter 8
	Client Validation...................................................................................................................... 43
	Overview 43
	Accessing Premise with Administrative Privileges 43
	Creating the Client Validation Data File 43
	Enabling West-Supplied Client Validation 44

	Chapter 9 Troubleshooting Premise........................................................................................................ 47
	Overview 47

	Introduction
	Configuring Premise on a Local Area Network
	Copying West CD-ROM Libraries Data to a Hard Drive
	Maintaining Your Library
	Changing Preferences
	Setting Up Your Printer
	Setting Up Communications
	Client Validation
	Troubleshooting Premise



